CCNA Lab

CCNA Lab Video Tutorial 6 – Router as DHCP Server

Posted on July 10, 2009. Filed under: CCNA, CCNA Lab | Tags: , , , |

In this tutorial, we will learn how to configure a router as DHCP server.

The project setup includes one 2621XM Routers, one 2650-24 Switch and 3 Generic End Devices.

Router’s interface fa0/0 are connected with Switch’s interface fa0/1 via a Copper Straight Through cable. The switch is connected with the PCs via Copper Straight Through cables. The ip address of the router’s FastEthernet0/0 (fa0/0 in short) interface will be configured as 192.168.10.1 with subnet mask 255.255.255.0.

dhcp

For this lab, you will enable the DHCP server for the 192.168.10.0/24 interface using a pool of addresses from 192.168.10.11 through 192.168.10.254 (by excluding addresses range from 192.168.10.1 through 192.168.10.10 from the pool). This router (with address 192.168.10.1/24) will be advertised as the default gateway to the clients.

We have walked through the dhcp configuration commands in tutorial 2 – dhcp, here I will explain the key steps.

To define the DHCP address pool, we need to firstly name it. we use the following command under global configuration mode:

R1(config)#ip dhcp pool POOLNAME

In our lab, the following command names the dhcp pool as “IP10”, it also brings router to the dhcp configuration mode:

R1(config)#ip dhcp pool IP10

The IP address that the DHCP server assigns are drawn from a common pool that you configure by specifying a range of usable IP addresses. The range of the usable IP addresses is specified by firstly assign a chunk of addresses to the pool with command “net NETADDRESS NETMASK“, then exclude some ip addresses from the pool with command “ip dhcp excluded-address STARTADDRESS ENDADRESS“. Note that the address range that you specify must also be in the subnet as the IP address of the LAN interface (in our lab, the subnet is 192.168.10.0/24, where the FastEthernet 0/0 interface belongs to).

To set the IP addresses to be used by the address pool, use the following command under dhcp configuration mode:

R1(dhcp-config)#network NETADDRESS NETMASK

In this lab, the following command assigned all the 254 addresses of subnet 192.168.10.0/24 to the pool.

R1(dhcp-config)#net 192.168.10.0 255.255.255.0

To configurer the ip addresses to be excluded from the pool, use the following command under dhcp configuration mode:

R1(dhcp-config)#ip dhcp excluded-address STARTADDRESS ENDADRESS

In our lab, we excluded the addresses range from 192.168.10.1 through 192.168.10.10 from the dhcp pool:

R1(config)#ip dhcp exc 192.168.10.1 192.168.10.10

Optionally, we can also assign a default gateway to the clients. To provide the default gateway IP address, use the following command under dhcp configuration mode:

R1(dhcp-config)#default-router IPADDRESS

For example, the following command set 192.168.10.1 as the default gateway:

R1(dhcp-config)#default 192.168.10.1

Optionally, we can also assign dns servers to the clients. To provide a dns server’s IP address, use the following command under dhcp configuration mode:

R1(dhcp-config)#dns-server IPADDRESS

In our lab, we set the dns-server address to 192.168.10.1:

R1(dhcp-config)#dns-server 192.168.10.1

On some cisco routers, you need to turn on the dhcp service with command:

R1(config)#service dhcp

To debug DHCP, use command:

R1(config)#debug ip dhcp server

To see if an address in the DHCP pool is already in use by another device, use command:

R1(config)#show ip dhcp conflict

To display address bindings on the cisco dhcp server, use command:

R1(config)#show ip dhcp binding

————————–the following is the CLI for this lab, some commands are slightly different from this video tutorial——————————

System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
cisco 2621 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory

Self decompressing the image :
########################################################################## [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software – Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706

Cisco Internetwork Operating System Software
IOS ™ C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang

cisco 2621 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory
.
Processor board ID JAD05190MTZ (4292891495)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
         — System Configuration Dialog —

Continue with configuration dialog? [yes/no]: n
Press RETURN to get started!

Router>enable
Router#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
side note: step 1, configure interface fa0/0. 
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

side note: “no shutdown” brings up the fa0/0 interface, the red dots on the link between router and switch changed to green after about 30 seconds.
R1(config-if)#exit

side note: step 2, create a dhcp pool under global configuration mode.
R1(config)#ip dhcp ?
  excluded-address  Prevent DHCP from assigning certain addresses
  pool              Configure DHCP address pools
R1(config)#ip dhcp pool IP10

side note: step 3, configure the dhcp pool’s range, default gateway, dns server under dhcp configuration mode.
R1(dhcp-config)#?
  default-router  Default routers
  dns-server      Set name server
  exit            Exit from DHCP pool configuration mode
  network         Network number and mask
  no              Negate a command or set its defaults
R1(dhcp-config)#network 192.168.10.1 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit

side note: step 4, configure excluded ip addresses from the dhcp pool.
R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.10
R1(config)#exit
%SYS-5-CONFIG_I: Configured from console by console

side note: step 5, now check the running configurations and save them.
R1#show running-config
Building configuration…

Current configuration : 484 bytes
!
version 12.2
no service password-encryption
!
hostname R1
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
ip classless
!
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool IP10
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
 dns-server 192.168.10.1

!
line con 0
line vty 0 4
 login
!
!
end
R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]

side note: step 6, check what ip addresses have been assigned to the clients. Since no client requires ip address at this point, we got an empty table. 
R1#show ip dhcp binding
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
side note: step 7, Now open the command line window in client PC0, make sure it has no ip address assigned to it with command “ipconfig /all”. Require a new ip address for PC0 with command “ipconfig /renew”.

cmd

side note: step 8, Go back to the router’s CLI, issue command “show ip dhcp binding” again. Note that the ip address 192.168.10.11 has been associated to PC0’s MAC address 00E0.B027.2B35. 

R1#show ip dhcp binding
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
192.168.10.11    00E0.B027.2B35           —                     Automatic
R1#

———————————————————————————————————————————————————————

Cisco DHCP IOS command references

Here’s another suplement video tutorial:

CCNA Lab Video Tutorial

Advertisements
Read Full Post | Make a Comment ( 5 so far )

CCNA Lab Video Tutorial 5 – Internet Connections with NAT and PAT

Posted on July 10, 2009. Filed under: CCNA, CCNA Lab | Tags: , , , |

In this tutorial, we will learn how to configure Internet connections with NAT and PAT. If you need a review of NAT and PAT concepts, cisco learning center have a nice video tutorial.

In project 1, we will configure static NAT on a Router.

The project setup includes two 2620XM Routers with Module WIC-2T installed (Router A and Router B).

Router A’s interface serial0/0 are connected with Router B’s interface serial0/0 via a serial DCE cable (don’t forget to set clock rate for both Routers). Router A have a loopback interface 0, which can be created with command:

RouterA#config terminal

RouterA(config)#int loopback 0

In project 2, we will configure NAT overload/PAT on a Router. The project2’s setup is the same as project1, except we have 2 loopback interface loopback0 and loopback1.

Configure static NAT:

To specify the global interface, go to the interface configuration mode and issue command,

RouterA(config-if)#ip nat outside

To specify the local interface, go to the interface configuration mode and issue command,

RouterA(config-if)#ip nat inside

To establish static translation between an inside local address and an inside global address, issue command,

RouteA(config)#ip nat inside source static LOCAL_ADDRESS GLOBAL_ADDESS

Example:

RouteA(config)#ip nat inside source static 172.16.1.1 10.0.0.1


 

Configure NAT overload:

To specify the global interface, go to the interface configuration mode and issue command,

RouterA(config-if)#ip nat outside

To specify the local interface, go to the interface configuration mode and issue command,

RouterA(config-if)#ip nat inside

To define a pool of global addresses that would be employed in the translation,

Router(config)#ip nat pool POOLNAME START_IP END_IP netmask NETMASK

example:

Router(config)#ip nat pool fastpool 20.0.0.1 20.0.0.10 netmask 255.255.255.0

To associate the pool and the local range in a dynamic NAT translation command,

Router(config)#ip nat inside source list LISTNUMBER pool POOLNAME overload

example:

Router(config)#ip nat inside source list 1 pool fastpool overload

If you have only one global address which can be employed in the translation.

 

To associate the interface and the local range in a dynamic NAT translation command,

Router(config)#ip nat inside source list LISTNUMBER interface INTERFACE overload

example:

Router(config)#ip nat inside source list 1 interface s 0/0 overload

To define the range of local addresses permitted to participate in the translation using an access-list.

Router(config)#access-list LISTNAME permit LOCAL_ADDRESS NETMASK

Example:

Router(config)#access-list 1 permit 192.168.0.0 0.0.255.255

Debug nat configuration

RouteA#debug ip nat

RouteA#show ip nat translations


Configure default routing

To send all traffic out of serial interface 0/0, issue command,

RouterB(config)#ip route 0.0.0.0 0.0.0.0 s 0/0


RouteA#ping
Protocol [ip]:
Target IP address: 192.168.1.2
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: loopback 0
% Invalid source
Source address or interface: Loopback 0
% Invalid source
Source address or interface: 192.16.1.1
% Invalid source
Source address or interface: loopback0
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.1
NAT: s=172.16.1.1->10.0.0.1, d=192.168.1.2[0]
NAT*: s=192.168.1.2, d=10.0.0.1->172.16.1.1[0]!

Advanced ping

RouteA#ping

Protocol [ip]:

Target IP address: 192.168.1.2

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: loopback0

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.1.1

NAT: s=172.16.1.1->10.0.0.1, d=192.168.1.2[0]

NAT*: s=192.168.1.2, d=10.0.0.1->172.16.1.1[0]!

CCNA Lab Video Tutorial

Read Full Post | Make a Comment ( 4 so far )

CCNA Lab Video Tutorial 4 – Configuring STATIC ROUTING, RIP, EIGRP and OSPF

Posted on July 9, 2009. Filed under: CCNA, CCNA Lab | Tags: , , , |

We have learned the basic cisco routing commands from CCNA Lab Video Tutorial 3, we also became familiar with the user interface of packet tracer from CCNA Lab Video Tutorial 2— we now know how to setup virtue lab, trouble-shoot network problems and simulate the network traffic.

The next tutorials will target the specific exam topics described in CCNA Exam Descriptions.

640-822 ICND1 Exam Description requires  “operating and configuring IOS devices; configuring RIPv2, static and default routing; implementing NAT and DHCP; and configuring simple networks.”

640-822 ICND2 Exam Description requires “configuring, verifying and troubleshooting VLANs; the VTP, RSTP, OSPF and EIGRP protocols; determining IP routes; managing IP traffic with access lists; NAT and DHCP; establishing point-to- point connections; and establishing Frame Relay connections.”

In this tutorial, we will learn how to configure STATIC ROUTING, RIP, IGRP and OSPF on cisco Routers.

The project setup includes two 2620XM Routers with Module WIC-2T installed (Router A and Router B) and two Generic End Devices (Host A and Host B).  If you are not sure how to install modules on a router or how to configure Gateway and IP address for End Devices, please review CCNA Lab Video Tutorial 2.

The Gateway of Host A is 10.0.0.1 and ip address is 10.0.0.10 with subnet mask 255.0.0.0.

The Gateway of Host B is 30.0.0.1 and ip address is 30.0.0.10 with subnet mask 255.0.0.0.

Router A’s interface serial0/0 are connected with Router B’s interface serial0/0 via a serial DCE cable (don’t forget to set clock rate for both Routers). Router A’s interface FastEthernet0/0 are connected with Host A’s FastEthernet0/0 via a Copper Cross-over cable. Router B’s interface FastEthernet0/0 are connected with Host B’s FastEthernet0/0 via a Copper Cross-over cable.

EIGRP stands for Extended IGRP protocal. For review of IP routing, watch this CCNA TV at cisco learning center.

routing-protocal-setup


STATIC ROUTING commands for Router A and Router B

ip route 10.0.0.0 255.0.0.0 20.0.0.2

more…

RIP ROUTING commands for Router A and Router B

router rip

network 20.0.0.0

network 10.0.0.0

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface s 0/0
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to down
Router(config-if)#exit
Router(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.2
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip int brif
^
% Invalid input detected at ‘^’ marker.
 
Router#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.0.0.1        YES manual up                    down
Serial0/0              20.0.0.1        YES manual down                  down
Serial0/1              unassigned      YES manual administratively down down
Router#

EIGRP Routing Commands for Router A and Router

router eigrp 111

network 20.0.0.0

network 10.0.0.0

more…

OSPF Routing Commands for Router A and Router B

router ospf 123

network 20.0.0.0 0.255.255.255 area 0

network 30.0.0.0 0.255.255.255 area 0

more…

CCNA Lab Video Tutorial

 

 

 

Read Full Post | Make a Comment ( 1 so far )

CCNA Lab Video Tutorial 3 – Cisco Router Basic Commands

Posted on July 8, 2009. Filed under: CCNA, CCNA Lab | Tags: , , , |

In CCNA Lab Video Tutorial 2, We have learned how to setup and trouble-shoot a cisco virtue lab with Packet Tracer 5.0. We also learned how to build a basic home LAN with a hub or switch, we even went a step future by inter-connecting two home LANs with a router. Now it’s time to connect routers and configure them with basic ISO commands. Familiar with cisco ISO commands are essential to pass the CCNA test, as described in exam blue print.

In the following three tutorials, we will learn the basic router configuration with a simple project setup.  This project include three 2621XM Routers, two of them (Router0 and Router1) are installed with WIC-2T Module. (If you are not sure how to install modules on a router, please review CCNA Lab Video Tutorial 2. ) Router0’s interface serial0/0 are connected with Router1’s interface serial0/0 via a serial DCE cabl. Router0’s interface FastEthernet0/0 are connected with Router2’s FastEthernet0/0 via a Copper Cross-over cable.

setup

device

Video 1 :Configure Router’s FastEthernet Interface.

Video 2:Configure Router’s Serial Interface.

Video 3:Configure Routing Protocal.

CCNA Lab Video Tutorial

Read Full Post | Make a Comment ( 5 so far )

CCNA Lab Video Tutorial 2 – Packet Tracer Interface overview

Posted on July 6, 2009. Filed under: CCNA, CCNA Lab | Tags: , , , |

ICND1 and ICND2 break down

In my previous post, I have introduced the packet tracer and how to download packet tracer from cisco website.
In the next posts, I will introduce how to use packet tracer with a series of video tutorials.
This video tutorial is a step by step demonstration of how to create a virtue lab with packet tracer 5.0. After watching the video, you will be able to select network devices, put them into the logical workspace and connect them with proper cables. You will also learn how to put different modules into the router’s slots and inspect the command line interface.


The best way of learning a software is to play with it. The packet tracer have an intuitive user-interface and flash-movie tutorial to walk you through the main features.

To strenghen the materials we have just learned, here are more hello-world style virtue lab setup.

Exercise 1: Connect 3 PCs with hub or switch

Trouble-shooting tip: How to trouble-shooting Connection problem

Exercise 2: Connect 2 Switches with Router

Exercise 3: DHCP setup

CCNA Lab Video Tutorial

Read Full Post | Make a Comment ( 4 so far )

CCNA Lab Video Tutorial 1 – CCNA virtue lab with Packet Tracer

Posted on July 6, 2009. Filed under: CCNA, CCNA Lab | Tags: , , , |

To pass the cisco CCNA test,  tester need to demonstrate ability to configure and trouble-shoot the network devices such as routers, switches etc. Unfortunetly, setting up a cisco lab at home is expensive. Fortunetly, cisco provide us an virtue lab, a software called packet tracer, which simulates the behavior of the real-world devices.

ptrc

You can drag and drop virtue routers, switches, cables onto the panel, and connet them with virtue cables. You can take a close look at a virtue device  (photos taken from the real-world devices) or open the CLI to practice the cisco IOS commands.

In a short words, Packet Tracer simulates physical equipment and provides students learning opportunities that are obtained in the real-world office or lab.

Packet Tracer 5.1 is the latest version, which can be downloaded from Cisco Networking Academy’s website.

I have created a seriers of easy to follow video tutorial on how to use Packet Tracer for CCNA certification.

How to Download Packet Tracer 5.0.

If you use Linux system, this post may help you.

This personal website is also talking about the packet tracer, you may want to check out the/Public/Cisco/Programs/PacketTracer/ directories he mentioned.

CCNA Lab Video Tutorial

Read Full Post | Make a Comment ( 3 so far )

Liked it here?
Why not try sites on the blogroll...